MagSafe toggles green/orange (part 2)

Published 28 Jan 2010

I have some strange updates regarding the greeen/orange blinking MagSafe I wrote about yesterday, where the LED on the MagSafe toggles between green orange, even though my new battery is fully loaded.

When I tried the battery in a friend’s computer, it worked perfectly…and while trying the battery at her place, the MagSafe indicator worked even in my MacBook! Yet, when I came home, the blinking re-appeared, and even continued when I tried another MagSafe connector. Straaaange times!

However, an even stranger thing has happened since then.

Before going to bed yesterday (after reading about blinking and exploding MagSafe connectors for hours) I decided to install OS X upgrades. The upgrade notes said something abot adjusting the computer for new hardware (strange) and then I shut it down for the night.

When I then started the computer this morning, the MagSafe no longer blinked! It actually seems to work! Either, my MagSafe connector is faulty and the other one I tried is loose or broken as well (quite unlikely), or I just had to install an additional driver update for the battery. I don’t understand this at all, but as long as the blinking have stopped, I am mr. Happy.

Update: At 10:30 am, the MagSafe LED indicator started blinking once more. Seems like it does not blink when I have had the MagSafe disconnected for a while, but since my neighbor’s MagSafe blinked with my computer and the battery is replaced, the only thing left is the computer.